Unable to login via mobile app

Incident Report for Visualogyx System Status

Postmortem

Issue was resolved at 7:56am EST.

Posted Aug 21, 2025 - 13:40 EDT

Resolved

We're currently experiencing a login outage on our mobile app. Our team is working to restore access ASAP. Thank you for your patience.
Posted Aug 21, 2025 - 07:45 EDT